[RESOLVED] - A device swap that half-worked

erik123erik123 Novice 0
I am trying to complete a swap from an old phone to a new phone. The swapped returned an error: "There was a problem swapping your device. If this new device is currently active on any carrier, it must be deactivated before swapping into your account. If you entered an ICCID, please try without the ICCID." I then did a PRL update on the new phone and the data and voice began to work on the new phone and they still work several days later. I checked the dashboard under "Your Device" and the MEID and ICC ID are still there for the old phone. I have a support ticket in for this but am wondering if anyone can help?
kurchov

Comments

  • JandAJandA MVP 24
    edited January 11
    Device swaps have been notoriously problematic lately and folks have had to try over and over dozens of times before the swap was successful.  You're the only one I've heard of that actually tried to update the new phone after the swap tool said it failed so not sure if this is what others would have experienced if they had not just kept trying the swap.  The prevalent advice being given now relative to swaps is to keep trying, ignore the "If you entered an ICCID, please try without the ICCID" statement and triple check the MEID and ICCID numbers and use cut and paste to enter them on each swap attempt.  Keep trying until it stops saying there was a problem.

    Edit: It's also recommended to use the BYOD checker (https://my.ringplus.net/device_validation_requests/new) and make sure it says your device can be activated immediately.

    akaLTDerik123jamielih
  • erik123erik123 Novice 0
    JandA, thanks for the response. The BYOD checker confirms the device is eligible for activation. Still trying to complete the swap to get the dashboard to show the correct MEID/ICCID. The good news is the new phone has voice and data and the old phone is inactive.
  • KentEKentE Moderator 167
    erik123:
    The BYOD checker confirms the device is eligible for activation.
    Is this the old phone?   If so, that's good (and you can probably fix the dashboard settings yourself.
    Swap back to the old phone, and swap again to the new phone-- this should give the dashboard a second attempt to update correctly.-- but read all the way through before trying it.......)

    The old MEID/ICCID still showing in your dashboard is a first for me, too.  I did have a swap recently that received the 'failure' message, but did actually swap the new phone in-- but it indicated correctly as such under "My Device".  
    I don't think this is an indication that this is what is typically happening with failed swaps, though.  Instead, I think it's likely an internal (to RP) error that isn't updating your dashboard correctly to reflect the new device being the active one.

    Since you do have a working phone;/ line, this might be considered a lower priority for Support to address-- but agree that you should follow up via a Support ticket if you view the swap back&forth as too risky..

    Please be very specific in the information in your ticket, and be clear that the functioning MEID/ICCID is the correct intended one.   I suspect that the dashboard needs to be "refreshed"  or cleared to reflect the already-correct network settings.

    It's kind of a sticky issue--you don't want Support to 'push' the current dashboard indicators back to the network, or your old phone will suddenly start working again........


    erik123
  • erik123erik123 Novice 0
    Thanks, KentE, for thinking this through. It all makes perfect sense. Good question about which device is eligible for activation. Yes, it is the old device. I am thinking I will wait for support to follow up on the ticket rather than swapping back to the old phone and trying again.
  • KentEKentE Moderator 167
    Thanks for confirming @erik123 ; ! 
    So, yes, you have a 'first time seen' oddity (for me, at least).  The old phone has been succesfully removed from the system, but just has it's old information "stuck" in the dashboard.
      Please make sure your ticket clearly spells out that you're only concerned with the device information shown in the dashboard itself, and not with the device presently active in the network.
    erik123
  • erik123erik123 Novice 0
    Thanks for the advice on the support ticket about dashboard vs. active device. I will be sure to add the comment on the current ticket.
  • erik123erik123 Novice 0
    Support followed up on the ticket on 1/17 and it was a straightforward solution. Support wrote "There was an issue with the device swap completing in the backend but not completing all the way. I have now correctly set your device on your line. Re-provision your device if needed....."
Sign In or Register to comment.