No notification of new voicemail messages

I was wondering why I don't get some king of notification when I have a voicemail message. I have Mad New Years #3 with the voicemail add on. I used to get texts and emails before I changed to this plan. I like having the feature but in a way it isn't very useful if there are messages waiting that I don't know about. Any Ideas besides a factory reset of my phone which isn't an option. Thanks

Comments

  • jamielihjamielih Moderator 127
    I believe with the Mad plans, the only voice mail notifications are whatever's available to Sprint voice mail users.

    In my case, I see a voice mail notification icon in my phone's notification area. The icon looks similar to https://goo.gl/images/z33At6
    Diedrich_DuoConic_EllipseVoIPFanRP
  • JandAJandA MVP 24
    @Zilla "I used to get texts and emails before I changed to this plan."

    Texts and emails were a feature of the R+ voicemail service which is no longer available since the plans that provided that service are also no longer available.  The Sprint voicemail we get with the Mad plans does provide indications of voicemails.  As @jamielih mentioned you'll see something in the phone's notification area and also the voicemail app that came on the phone should both show you the number of new voicemails and allow you to listen to them.  You could move that app to your home screen and then it would then be more visible to you.  I'm speaking relative to Android phones but I expect similar features are available on iPhones.  YMMV
    VoIPFanRP
  • akaLTDakaLTD Moderator 115
    edited January 11
    I'll relate my one experience after changing to Mad plan.

    My brothers phone didn't any get voicemail notification at all .. none in the notification bar or anyway to know without dialing to check. I think he did get missed call notification. We had disabled the native voicemail app not knowing there would be no way to re-enable it, if/when needed. Enable was greyed out. And the app/apk is not available for download anywhere.

    Restored the device to factory settings which restored the app and most important, the notification. May have just been co-incidence but it seemed if the voicemail app wasn't installed or working, voicemail notifications didn't work either ... like I said it could have just been that one phone, an LG Stylo and not pertinent to anyone or any other devices. ???
    VoIPFanRP
  • I also didn't get any notifications after switching to a Mad plan with voicemail.  So I went to Settings->Sound & notification->App notifications->Voicemail on my phone and found that it was set to "Block--Never show notifications from this app."  I turned that blocking off and my voicemail notifications started working.
    akaLTDZilla
  • akaLTDakaLTD Moderator 115
    Widsith:
    So I went to Settings->Sound & notification->App notifications->Voicemail on my phone and found that it was set to "Block--Never show notifications from this app."  I turned that blocking off and my voicemail notifications started working.
    Thanks for posting since others may find this very helpful. :+1:

    I need to remember to suggest this first for anyone with the no voicemail notification problem.
  • PromozePromoze All Star 125
    Here are a couple possibilities if you're not getting voicemail notifications:
    https://social.ringplus.net/discussion/comment/113905/#Comment_113905
  • why is ringplus suddenly charging for voice mail? It was always included with every plan up until the most recent plans, and everyone else includes this for free! Very shady ringplus, very shady indeed
  • akaLTDakaLTD Moderator 115
    wind-up-pearl-honeycomb-dolphin-689697:
    why is ringplus suddenly charging for voice mail? I
    Maybe because all calls are now routed through Sprint servers & using Sprint servers for voicemail rather than the old system of using R+ servers. And just maybe Sprint is charging R+ for this service so R+ is passing it along to members in order not to lose money.

    Maybe think about it before assuming the worst.


    JandA
  • ZillaZilla Novice 0
    akaLTD: 
    Widsith: 
    So I went to Settings->Sound & notification->App notifications->Voicemail on my phone and found that it was set to "Block--Never show notifications from this app."  I turned that blocking off and my voicemail notifications started working.

    I went into settings/ apps/ all/ voicemail and found show notifications was unchecked. After I checked it voicemail is now working correctly. I also couldn't find voicemail in my app drawer. I hid the app and forgot I did it. It is now unhidden and I can open it and check my voicemail that way too. After it started working again I remembered why I turned off the notifications in the first place. It started nagging me to subscribe @ $2.99 a month for transcriptions again. I ended the free trial now and all it good. Thanks everyone for your responses.
    WidsithakaLTD
Sign In or Register to comment.