Cancelled R+ account entirely, would that properly release both my MEID and ICCID

I have a S7 with 506 SIM activated on this account.  I cancelled the account entirely and waited a month to byod this phone to Freedompop.  Prior to the process, checked the MEID via ting and other byod checker to be clear.  I swapped in a brand new SIM and had to contact FP to update the ICCID info.  However, when I tried to use the old SIM that I swapped out for another byod case, I could not get LTE no matter what I do, and FP customer service told me that they ve seen quite a few cases like mine, and the no LTE problem is because the ICCID of SIM wasn't release properly by Ringplus.

Upon reading Howard Forum, people were saying canceling the account should release both MEID and ICCID immediately. How do I contact Ringplus now to verify that my ICCID was cleared to be used at another compatible device?

Thanks a lot.

BTW @KentE, this was the G930U (S7 official unlocked version) that you helped me diagnose for the mysterious loss of provision. (we concluded that it went limbo, and wasn't actually activated anywhere despite being listed as the active device under my account until the last day).


  • mmfacemmmmfacemm All Star 48
    edited June 2017
    If the MEID is showing as clear the ICCID will be clear too.  
    However I am not sure exactly what you are doing.  So you activated via freedompop with a new sim.  And it worked?  LTE data worked?  But then you swapped back to the old sim?  Did you get freedompop to swap the ICCID in your account to the old sim? And now LTE doesn't work?   If FP were able to add it to your line then the issue is not the sim- your settings need updating probably.  What ICCID shows in your account - the old sim? 

    Or did you just try to swap in the old sim without telling freedompop - that won't work

    PS There have been lots of random errors with sprint today - the tello meid checker not working, cellnuvo iphone data not working for an hour.  Maybe a temporary glitch that will resolve itself.  How long have you had this issue - just today? 

  • KentEKentE Moderator 168
    @GentDiors1 ;  I remember your issue!  Very unusual.
      If I understand your post above correctly, you managed to activate your S7 and have working data on FP with a new SIM card, after not having success with the original SIM card.   It sounds like you're trying to re-use the old SIM card to activate a different phone?
       If that's right-- to cut to the end, I doubt you'll get the old SIM to work without major gyrations, and it's iffy even then.  I agree with the FP CS that it's a not-infrequent occurrence, at RP or elsewhere on the Sprint network.   I don't know that it was really more likely to happen at RP-- it's Sprint that deactivates the SIM in their system, regardless of which MVNO, and I believe there's no separate request for deactivating a SIM-- the request is for the MEID to be released, which should automatically release the SIM. 

      The longer version:   as I understand it, for practical purposes the SIM should be released when the phone is released, and that's the only point in time when the system is set up for the SIM to be released.   If somehow the SIM did not get properly deactivated or released with the phone, doing so now would be very difficult.  I think we've seen it managed a couple of times in the past only by reactivating the phone on the same account it was previously active on, and then deactivating the phone again.   (And that can't happen, since there's no RP account left to activate the phone on........)  (Plus, your S7 wasn't ever properly activated when it was on RP, anyway.......and is probably the original cause of the non-working SIM)

    RingPlus no longer has a connection to the Sprint backbone, so no help would be possible through that avenue.   A very persistent tech at another MVNO might be able to get it done, but it's a long shot.

    Before giving up entirely, are you certain it's the right SIM # for the 'other' device?  If so, the usual path is just to trash the old SIM and replace it.
  • mmfacemmmmfacemm All Star 48
    nb the 506 sim doesn't work in all phones - just a select few.  Which one are you trying?
  • hhfpphonehhfpphone Ethical Committee 221
    I had a similar experience when I bought a used S4 and activated on Freedompop.  It was fixed when I moved my line to Ringplus and reported the LTE SIM was not released properly.  I bought a new LTE SIM and activated the phone on Ringplus and both 3G and LTE were working... that's one solution anyway.

    Otherwise, Freedompop should be able to work with Sprint to get the LTE SIM released... it is a question of willingness, IMHO.
  • GentDiors1GentDiors1 Novice 1
    edited June 2017
    @KentE @mmfacemm @hhfpphone

    Two S7 (G930U, P1 and P2) and two 506 SIMs (call it S1 and S2)

    P1+S1 was activated on Ringplus for a brief time with LTE, but it went into limbo after a port-in error at the beginning (despite showing as active device for my RP line, it was shown as clear Pfor activation on all other byod checkers), it lost the provision with RP as well (can't pass hfa after a reset).  I ended up cancelling the whole thing when RP went belly up just for the clean release of the device/sim.

    When I tried to byod P1 to FP, I chose to use S2 (brand new), since during the rp times, the most frequent answer to all sorts of network problem might be "use a new sim", so I wanted to start fresh. I actually don't know and won't be able to find out if P1 and S1 pair would naturally work on FP, as Kent mentioned, the pair were having issue on RP and never resolved until its final days, but the pair of P1/S1 should still be the last known activation on sprint network for P1.  Noteworthy thing is, all my other rp or previously sprint devices (including LG volt, iphone 5s and ipad mini 2 LTE) were all working instantly with LTE after byod to FP (they all still have the factory SIM, and have all been activated on Sprint network with LTE prior to the FP times).

    FP actually automatically carry over P1/S1 as they were paired during the last activation, so I needed to update S2 iccid via their customer service (to clear the mismatch of info) to pass HFA and made 3G mobile data work.  Did all sorts of resets and edits trying to get LTE, but no success until overnight of 03/29-03/30, I powered it off with 3g only but next morning got LTE. That's why I thought it was something happened on their end.

    Now I'm trying to byod P2 (never activated) with S1.  When first byod, it obviously had an activation problem (red line shown in my fp account), but after providing S1 iccid, it passed the hfa and stuff, with 3G data working.  But this time, I've been having heck of a time to get back lte, did all the resets/edits posted online as remedy for no-LTE, waited almost two months (for the mysterious backend sync/refresh between fp and sprint), still no lte. FP customer service at twitter has not been very helpful, and got impatient gradually.  Finally the rep at SlickDeals replied my month old PM after a reminder, and brought this idea "rp may not release the iccid for S1 completely" to me, thus the question here.
  • mmfacemmmmfacemm All Star 48
    Have you tried editing the APN?  Probably.

    I'd just buy a new sim - not worth the hassle.  Seems like that sim has caused you nothing but problems.  
  • KentEKentE Moderator 168
    I suspect that the time & effort trying to get that SIM to work may not be worth the hassle.

    The 506 SIM is available from Sprint for $2.99, plus $10 shipping:  there's a decent chance you could get one at a local Sprint corporate store (or repair center) without the shipping cost.|All&question_box=sim%20card%20|All
    Best Buy might be another option for a source.  (In store, at the phone counter.)

    And of course the warning......   Sprint lists this as compatible for the Galaxy S7 Special Edition-- I've never been clear what the "Special Edition" is, but I note that it doesn't seem to include all S7's......   Some folks have had success with phones not listed as compatible with this SIM, some have had problems, including some with phones that specifically are on the compatibility list.   I know Ting recommends not using the 506 SIM unless there's no other listed option.

    Ting recommends SIMOLW416C

Sign In or Register to comment.