any CM 14.1 user's here need help with LTE

Hi hoping some one here has tried this rom  CM 14.1  I did a flash on a Samsung galaxy s4 sph-l720  and when the sim card is in the service flashes in and out and no apns appear if I remove the sim card the apns appear and I use the correct one but only get 3g speed and can't get lte speed any help from the pros would be great thanks for reading.

Comments

  • The problem is the framework for LTEonCDMA. It's a problem with all CM 14 builds. You might try builds of Resurrection Remix or AICP. I think they might have an unofficial framework.that fixes the problem.


    Another suggestion on xda is to flash your original efi partition after you flash the ROM.


    Good luck.
    jeffreycamacho
  • AnytomAnytom Pro 6
    edited January 27
    sleek-magenta-wavy-nerf-gun-465131:
    Another suggestion on xda is to flash your original efi partition after you flash the ROM.

    That is what I would suggest: First flash stock ROM, boot it up and make sure everything is working: Voice, SMS, MMS, and LTE. If you have problems, then perform a carrier wipe (##72786#) and wait at least 5 minutes after reboot for the phone to be provisioned on Sprint. Then perform PRL and Profile Updates. Now use TWRP to backup the EFS partition which holds radio information (not EFI, that's something else). Now, after flashing CM14.1 (or restoring a nandroid backup) restore the backed up EFS partition in TWRP.

    Once booted in the ROM, you may have to toggle Airplane mode from time to time if you have connection problems.

    I don't have the Samsung S4 myself, but a Nexus 5. Yes, that is a different phone, however the problem is similar because there are no stock Nougat ROMs for Nexus 5 anymore (although Google still provides Marshmallow updates). That means any Nougat custom ROMs for Nexus 5 do not include the full set of radio files and drivers for Nexus 5, since they don't have a Nexus 5 stock Nougat ROM from which to copy them. That basically means no Sprint support without these workarounds. Or stay with Marshmallow ROMs which DO include the radio files and drivers from Google's stock Marshmallow ROM.


    jeffreycamacho
  • Anytom:
    (not EFI
    Yes, sorry. I meant EFS.

  • I just tried flashing an AICP rom 7.1 on my LG G3 and it does have the problem. I flashed my stock EFS partition and it seems to fix it, but it's too early to tell. I will let you know how it goes.
  • I thought CM is no longer and now is called LineageOS ?

    jeffreycamacho
  • AnytomAnytom Pro 6
    edited January 27
    sleek-magenta-wavy-nerf-gun-465131:
    Yes, sorry. I meant EFS.

    Yeah, I knew what you meant. But wanted to make it clear in case the OP or others didn't. :)
    sleek-magenta-wavy-nerf-gun-465131:
    I just tried flashing an AICP rom 7.1 on my LG G3 and it does have the problem. I flashed my stock EFS partition and it seems to fix it, but it's too early to tell. I will let you know how it goes.

    Good job! Was Sprint already activated when that EFS was backed up? Just curious...

  • Anytom:
    Was Sprint already activated when that EFS was backed up? Just curious...
    Yes, RingPlus was already working when I backed up.

  • sleek-magenta-wavy-nerf-gun-465131:
    Yes, RingPlus was already working when I backed up.

    Thanks, that explains it :)

  • first off thank you all you your replays I did flash back to the stock firmware rom 5.0.1 lollipop  that worked with the sim card plugged in and had LTE speed and did back up the EFS partition then flashed the CM 14.1 and restored EFS partition   and still had the same results as long as the simcard is plugged in the service just flickered in and out and the APNs did not appear , but just like before if I removed the sim card the APNs would appear and it worked but with only 3g not LTE  hopefully I can find a custom rom for this S4 that works really liked the CM 14.1 pretty snappy and fast and stable ..
  • alerts54321:
    I thought CM is no longer and now is called LineageOS ?

    and you are correct thanks again guys ..

  • AnytomAnytom Pro 6
    edited January 28
    @jeffreycamacho: I am sorry to hear it didn't work after going through all those steps.

    As the commit linked by @sleek-magenta-wavy-nerf-gun-465131 shows, the ROM apparently tries to switch to phone back to GSM. It would be better if it didn't have any CDMA support at all: The EFS you restored would work just fine if only the ROM would stop trying to change it. Hopefully everything will work once that commit is included.
    jeffreycamacho
  • Copy the ROM zip file to your computer and extract it using your decompressing software.
    nce unzipped, browse to the ‘META-INF/com/google/android’ directory. Here, you will find two files called ‘update-binary’ and ‘updater-script’
    Rename ‘updater-script’ to ‘updater-script.txt’ and open with your text file editor (You need to enable file extensions in the control panel to be able to do this)Get rid of the line starting with ‘assert’ to the next semi-colon. Usually this is the first line or one of the first lines at the top of the text file. Just delete them. Remove everything until the command ‘mount’ is visible.
    Save the file.Rename ‘updater-script.txt’ back to ‘updater-script’Re-compress all the files.Use this .zip file to flash the ROM.Get more details in Lg g3 Manual. 

Sign In or Register to comment.